Francisco Chaves

Francisco Chaves

Software Developer. Entusiasta Linux.

© 2020

Modo escuro

Pseudocódigo com Portugol Studio

Menino com um computador na frente e a logo do Portugol Studio

Olá pessoal, já realizamos a instalação da ferramenta Portugol Studio em outro post, hoje vamos utilizá-lo para criar um algoritmo para calcular a média aritmética das notas do aluno.

Abra o Portugol Studio:

Tela inicial do Portugol Studio

Clique em Novo Arquivo:

Crie novo arquivo

A tela exibida apoś criar o novo arquivo:

Tela do novo arquivo

Vamos declarar as variáveis (local onde vamos guardar os valores digitados pelo usuário), as notas e a média serão do tipo real para aceitar valores com ponto (por exemplo 7.5) e o nome do aluno será do tipo cadeia para armazenar letras.

programa
{
	funcao inicio()
	{
		real nota1,nota2,nota3,nota4
		cadeia nomeAluno
	}
}

Para exibir informações na tela utilize o comando escreva() com o texto entre aspas dentro dos parênteses:

programa
{
	funcao inicio()
	{
		real nota1, nota2, nota3, nota4, media
		cadeia nomeAluno

		escreva("Digite o seu nome:")
	}
}

Para guardar o valor digitado utilize o comando leia() com um variável dentro dos parênteses:

programa
{
	funcao inicio()
	{
		real nota1, nota2, nota3, nota4, media
		cadeia nomeAluno

		escreva("Digite o seu nome:")
		leia(nomeAluno)
	}
}

Para obter a média, o cálculo é somar as 4 notas e dividir por 4:

programa
{
	funcao inicio()
	{
		real nota1, nota2, nota3, nota4, media
		cadeia nomeAluno

		escreva("Digite o seu nome:")
		leia(nomeAluno)
		escreva("Digite a nota 1:")
		leia(nota1)
		escreva("Digite a nota 2:")
		leia(nota2)
		escreva("Digite a nota 3:")
		leia(nota3)
		escreva("Digite a nota 4:")
		leia(nota4)

		media = (nota1 + nota2 + nota3 + nota4) /4

		escreva(nomeAluno + " sua média é: " + media)
	}
}

Para saber se o aluno foi aprovado ou reprovado utilizamos o comando se() e dentro dos parênteses coloca-se uma condição e caso a condição seja falsa podemos utilizar o comando senao :

programa
{
	funcao inicio()
	{
		real nota1, nota2, nota3, nota4, media
		cadeia nomeAluno

		escreva("Digite o seu nome:")
		leia(nomeAluno)
		escreva("Digite a nota 1:")
		leia(nota1)
		escreva("Digite a nota 2:")
		leia(nota2)
		escreva("Digite a nota 3:")
		leia(nota3)
		escreva("Digite a nota 4:")
		leia(nota4)

		media = (nota1 + nota2 + nota3 + nota4) /4

		escreva(nomeAluno + " sua média é: " + media)

		se(media >= 5) {
			escreva("\n" + "Você foi aprovado!!!")
		} senao {
			escreva("\n" + "Você foi reprovado!")
		}
	}
}

Salve o arquivo:

Salve o arquivo

Execute o arquivo:

Execute o arquivo

Resultado da execução:

Resultado da execução

×

Inscreva-se para novas atualizações